moyashidaisuke's diary

平日はエンジニア、土日はミュージシャン(自称)のダイスケです。プログラム関連とかギター関連とかなんでも。

アプリのiPhoneX対応の必須化は更新も対象になったよ、という話

以前似たような記事を書いた時は必須じゃなかったのが必須になりました。

↓以前の記事 moyashidaisuke.hatenablog.com

オリジナルのソース

developer.apple.com

 Starting July 2018, all iOS app updates submitted to the App Store must be built with the iOS 11 SDK and must support the Super Retina display of iPhone X.

2018年7月から、全てのiOSアプリの更新で、iOS11SDKとSupreRetinaディスプレイの対応が必須になる、との事です。 なので、この記事を書いている今は既に必須になっています。

思ったより早かったですね、、、

時系列でまとめると、

  • 2018/2 「2018/4」から新規の時にiPhoneX対応が必須になるよアナウンス
  • 2018/4 新規の時にiPhoneX対応が必須になる
  • 2018/5 「2018/7」から更新も含めてiPhoneX対応が必須になるよアナウンス
  • 2018/7 更新の時にもiPhoneX対応が必須になる

Apple厳しいな〜と思っていたら、Androidでも同じような話があるようなので、こちらも注意が必要そうです。

qiita.com